Problems opening interlibrary loan documents

What to do if you are trying to open a document from the British Library and you get this error message:

This computer must be connected to the network in order to open this document. Connect this computer to the network and then try opening the document again.

This error occurs because Adobe no longer support old versions of Transport Layer Security.  Please click “Read more” (below) for instructions on how to resolve this issue.

Solution 1: upgrade Adobe Reader

You may need to upgrade your version of Adobe Reader. You need Adobe Reader DC or Adobe Acrobat DC (DC is the next version after 11).

How to tell if you have Adobe Reader installed:

  • Go to Start > All Programs
  • If you have it, it should be listed here.

How to tell which version you have:

  • Go to Start > All Programs
  • Open Adobe Reader.
  • Go to Help > About Adobe Reader

How to get the latest version:

  • On campus, go to AppsAnywhere and launch Adobe Acrobat DC.
  • Off campus, you can download Adobe Acrobat Reader for free from: https://get.adobe.com/uk/reader/.
  • For mobile devices, visit the app store.

When you open the document from the British Library, make sure you select Open With > Adobe Reader DC. Do not open with older versions such as X or XI.

 

Solution 2: enable TLS 1.2

If updating your version of Adobe Reader doesn’t help, you may need to enable a new version of Transport Layer Security (TLS) on your computer. To enable TLS 1.2, follow these instructions, depending on the browser you are using.

If you have any questions, do get in touch.

Posted in Services