Ebsco to stop supporting Internet Explorer 8 and 9

internet explorer photoFrom July 2017 (during the next summer vacation), Ebsco will stop supporting Internet Explorer 8 and 9.  These are very old versions of this browser (the University at time of writing offers IE 11).  If you are running a version earlier than IE 10, please either update it to a later version or install another browser.  We recommend the latest version of Chrome for use with electronic Library resources.

Photo by LearnerWeb

Posted in Services Tagged with: ,